AudioDisplay2Lib

NCTAudioStudio2 ActiveX DLLs
NCTAudioDisplay2 ActiveX DLL

Version 2.2

NCTAudioDisplay2 ActiveX DLL is intended for visual representation of the left and right channels of audio data in the process of playback or record.

NCTAudioDisplay2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTAudioDisplay2 documentation.
NCTAudioDisplay2 was developed by NCT Company Ltd. http://www.nctsoft.com


AudioDisplay2 properties

properties (AudioDisplay2 object)

Property | Type | Default | Description
ArrayChannels | ChannelsConstants |  | Gets or sets the number of channels.
ArrayFrequency | FrequencyConstants | FQ_44_KHZ | Gets or sets the frequency of the audio array.
AttackTime | Long |  | Gets or sets the speed of the increase of the visualized loudness (for amplify bar of the signal).
BackColor | OLE_COLOR |  | Gets or sets RGB color of background using standard Windows palette.
BorderColor | OLE_COLOR |  | Gets or sets RGB color of the border using standard Windows palette.
BorderStyle | BorderTypeConstants |  | Gets or sets the type of the border.
FFTWindowsSize | Long |  | Gets or sets visualized audio data array size.
InscriptionsColor | OLE_COLOR |  | Gets or sets RGB color of inscriptions using standard Windows palette.
LevelsColor | OLE_COLOR |  | Gets or sets RGB color of level using standard Windows palette.
MaxLevel | Integer |  | Gets or sets the maximal level of visualized audio data.
MaxLevelColor | OLE_COLOR |  | Gets or sets RGB color of maximal level using standard Windows palette.
OutLinesHeight | Integer |  | Gets or sets the height of the lines.
ReleaseTime | Long |  | Gets or sets the speed of the decrease of visualized loudness (for amplify bar of the signal).
ScaleColor | OLE_COLOR |  | Gets or sets RGB color of the scale using standard Windows palette.
TypeDisplay | TypeDisplay |  | Gets or sets the type of visualization.


ArrayChannels property (AudioDisplay2)

ArrayChannels property (AudioDisplay2)

Gets or sets the number of channels.

Property type

A ChannelsConstants value.

Syntax

object.ArrayChannels [= value]

The ArrayChannels property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | ChannelsConstants | Number of channels.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim nChannels As ChannelsConstants
nChannels = Display.ArrayChannels

See Also:

ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


ArrayFrequency property (AudioDisplay2)

ArrayFrequency property (AudioDisplay2)

Gets or sets the frequency of the audio array.

Property type

A FrequencyConstants value.

Syntax

object.ArrayFrequency [= value]

The ArrayFrequency property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | FrequencyConstants | Frequency is in hertz. By default is set to 44100.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Frequency As FrequencyConstants
nChannels = Display.ArrayFrequency

See Also:

ArrayChannels | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


AttackTime property (AudioDisplay2)

AttackTime property (AudioDisplay2)

Gets or sets the speed of the increase of the visualized loudness (for amplify bar of the signal).

Property type

A Long value.

Syntax

object.AttackTime [= value]

The AttackTime property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | Long | Degree of speed modification.

Remarks:

Usually the value of AttackTime property is much less than ReleaseTime.

This properties is used for visual approaching to early analog variants of amplify bar.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


BackColor property (AudioDisplay2)

BackColor property (AudioDisplay2)

Gets or sets RGB color of background using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.BackColor [= value]

The BackColor property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color type. By default this property is set to window background color.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


BorderColor property (AudioDisplay2)

BorderColor property (AudioDisplay2)

Gets or sets RGB color of the border using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.BorderColor [= value]

The BorderColor property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color type.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


BorderStyle property (AudioDisplay2)

BorderStyle property (AudioDisplay2)

Gets or sets the type of the border.

Property type

A BorderTypeConstants value.

Syntax

object.BorderStyle [= value]

The BorderStyle property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | BorderTypeConstants | The type of border style.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


FFTWindowsSize property (AudioDisplay2)

FFTWindowsSize property (AudioDisplay2)

Gets or sets visualized audio data array size.

Property type

A Long value.

Syntax

object.FFTWindowsSize [= value]

The FFTWindowsSize property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | Long | Size of visualized audio data array, in samples.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


InscriptionsColor property (AudioDisplay2)

InscriptionsColor property (AudioDisplay2)

Gets or sets RGB color of inscriptions using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.InscriptionsColor [= value]

The InscriptionsColor property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color of inscriptions.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


LevelsColor property (AudioDisplay2)

LevelsColor property (AudioDisplay2)

Gets or sets RGB color of level using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.LevelsColor [= value]

The LevelsColor property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color of level.

Remarks:

Visualized audio data has two colors: LevelsColor for the part of the line with the volume of audio data less than MaxLevel and MaxLevelColor for the part of the line with the volume of audio data more than MaxLevel. This property is used only for amplify bar of the signal.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


MaxLevel property (AudioDisplay2)

MaxLevel property (AudioDisplay2)

Gets or sets the maximal level of visualized audio data.

Property type

An Integer value.

Syntax

object.MaxLevel [= value]

The MaxLevel property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | Integer | Level of visualized audio data, in db. Varies from 0 to -91.

Remarks:

Visualized audio data has two colors: LevelsColor for the part of the line with the volume of audio data less than MaxLevel and MaxLevelColor for the part of the line with the volume of audio data more than MaxLevel. This property is used only for amplify bar of the signal.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


MaxLevelColor property (AudioDisplay2)

MaxLevelColor property (AudioDisplay2)

Gets or sets RGB color of maximal level using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.MaxLevelColor [= value]

The MaxLevelColor property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color of maximal level.

Remarks:

Visualized audio data has two colors: LevelsColor for the part of the line with the volume of audio data less than MaxLevel and MaxLevelColor for the part of the line with the volume of audio data more than MaxLevel. This property is used only for amplify bar of the signal.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | OutLinesHeight | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


OutLinesHeight property (AudioDisplay2)

OutLinesHeight property (AudioDisplay2)

Gets or sets the height of the lines.

Property type

An Integer value.

Syntax

object.OutLinesHeight [= value]

The OutLinesHeight property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | Integer | The height of the lines.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | ReleaseTime | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


ReleaseTime property (AudioDisplay2)

ReleaseTime property (AudioDisplay2)

Gets or sets the speed of the decrease of visualized loudness (for amplify bar of the signal).

Property type

A Long value.

Syntax

object.ReleaseTime [= value]

The ReleaseTime property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | Long | Degree of speed modification.

Remarks:

Usually the value of AttackTime property is much less than ReleaseTime.

This properties uses for visual approaching to early analog variants of amplify bar.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ScaleColor | TypeDisplay

Apples To: AudioDisplay2


ScaleColor property (AudioDisplay2)

ScaleColor property (AudioDisplay2)

Gets or sets RGB color of the scale using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.ScaleColor [= value]

The ScaleColor property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color of the scale.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | TypeDisplay

Apples To: AudioDisplay2


TypeDisplay property (AudioDisplay2)

TypeDisplay property (AudioDisplay2)

Gets or sets the type of visualization.

Property type

A TypeDisplay value.

Syntax

object.TypeDisplay [= value]

The TypeDisplay property syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object.
value | TypeDisplay | Type of data visualization.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

ArrayChannels | ArrayFrequency | AttackTime | BackColor | BorderColor | BorderStyle | FFTWindowsSize | InscriptionsColor | LevelsColor | MaxLevel | MaxLevelColor | OutLinesHeight | ReleaseTime | ScaleColor

Apples To: AudioDisplay2


AudioDisplay2 Methods

methods (AudioDisplay2 object)

Method | Description
Register | Enters user name and registration password to disable About window.
SendArray | Sends audio data array for visual representation.


Register method

Register method

Enters user name and registration password to disable About window.

Syntax

object.Register(bstrUser As String, bstrPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object of type .
bstrUser | String | User name. You get a registration user name after the registration.
bstrPassword | String | Password string. You get a registration password after the registration.

Example:

' VB sample where Display is an AudioDisplay2 object.
Display.Register "XXX", "XXX"

See Also:

Apples To: AudioDisplay2


SendArray method

SendArray method

Sends audio data array for visual representation.

Syntax

object.SendArray(InputArray As Integer())

The SendArray method syntax has these parts:

Part | Type | Description
object | AudioDisplay2 | An expression evaluating to an object of type .
InputArray | Integer() | Audio data array.

Example:

' VB sample where Display is an AudioDisplay2 object.
Dim Array() As Integer
...
'Filling of Array() array.
...
Display.BackColor = System.Drawning.Color.Gray
Display.BorderColor = System.Drawning.Color.Blue
Display.InscriptionsColor = System.Drawning.Color.Blue
Display.LevelsColor = System.Drawning.Color.Pink
Display.MaxLevelColor = System.Drawning.Color.Khaki
Display.ScaleColor = System.Drawning.Color.Blue
Display.BorderStyle = bSingle
Display.FFTWindowsSize = 1024
Display.MaxLevel = 41
Display.OutLinesHeight = 14
Display.AttackTime = 2
Display.ReleaseTime = 200
Display.TypeDisplay = tdOutLine
Display.SendArray Array()

See Also:

Apples To: AudioDisplay2


NCTAudioDisplay2 constants

NCTAudioDisplay2 constants

Constants | Description
BorderTypeConstants | These are the constants for the BorderStyle property (AudioDisplay2).
ChannelsConstants | These are the constants for the ArrayChannels property (AudioDisplay2).
FrequencyConstants | These are the constants for the ArrayFrequency property (AudioDisplay2).
TypeDisplay | These are the constants for the TypeDisplay property (AudioDisplay2).


BorderTypeConstants enumeration

BorderTypeConstants enumeration

These are the constants for the BorderStyle property (AudioDisplay2).

Members

Constant | Value | Description
bNone | 0 | Without border.
bSingle | 1 | Single border.
bLowered | 2 | Lowered border.
bRaised | 3 | Raised border.


ChannelsConstants enumeration

ChannelsConstants enumeration

These are the constants for the ArrayChannels property (AudioDisplay2).

Members

Constant | Value | Description
MONO | 1 | Mono data uses one channel.
STEREO | 2 | Stereo data uses two channels.


FrequencyConstants enumeration

FrequencyConstants enumeration

These are the constants for the ArrayFrequency property (AudioDisplay2).

Members

Constant | Value | Description
FQ_96_KHZ | 48000 | 96000 hertz.
FQ_88_KHZ | 44100 | 88200 hertz.
FQ_48_KHZ | 48000 | 48000 hertz.
FQ_44_KHZ | 44100 | 44100 hertz.
FQ_32_KHZ | 32000 | 32000 hertz.
FQ_24_KHZ | 24000 | 24000 hertz.
FQ_22_KHZ | 22050 | 22050 hertz.
FQ_16_KHZ | 16000 | 16000 hertz.
FQ_12_KHZ | 12000 | 12000 hertz.
FQ_11_KHZ | 11025 | 11025 hertz.
FQ_8_KHZ | 8000 | 8000 hertz.
FQ_6_KHZ | 6000 | 6000 hertz.


TypeDisplay enumeration

TypeDisplay enumeration

These are the constants for the TypeDisplay property (AudioDisplay2).

Members

Constant | Value | Description
tdOutLine | 0 | Amplify bar of signal.
tdAnalog | 1 | Analog signal.
tdFFTFire | 2 | Fire shape of spectrum.
tdFFTGlass | 3 | Glass shape of spectrum.
tdFFTKryptonite | 4 | Kryptonite shape of spectrum.


AudioDisplay2

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTAudioDisplay2 ActiveX DLL is intended for visual representation of the left and right channels of audio data in process of playback or record.

NCTAudioDisplay2 is a part of the NCTAudioStudio2 package.


AudioDisplay2Lib

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTAudioDisplay2 ActiveX DLL is intended for visual representation of the left and right channels of audio data in process of playback or record.

NCTAudioDisplay2 is a part of the NCTAudioStudio2 package.